You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 646 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 4 posts

Thursday, July 12th 2012, 5:09pm

by Central Irrigation

Rinse and repeat. Are you sure you don't have dirt inside the valve that is finding it's way into the selonoid? I'm assuming you pulled off the white retainer cap from the selonoid to access the plunger. Is this retainer cap damaged in any way?

Thursday, July 12th 2012, 3:43pm

by mannyrem

valve sticking

Thank you mrfixit for your reply. Tried your suggestions,still have the same problem. I just tap the solenoid and it shuts down.

Thursday, July 12th 2012, 11:02am

by mrfixit

When the valve is stuck on try turning the flow control down a bit. See if it doesn't shut off normally when you do that.
You don't want the flow control open all the way or it might stick on.

Also, make sure the solenoid is snug. A loose solenoid could cause it to stay on. Turn the solenoid clockwise as well as the handle below the solenoid.

Thursday, July 12th 2012, 9:24am

by mannyrem

solenoid sticking

I replaced a valve with a brand new irritrol valve,the zone will not shut off when cycle is complete,solenoid sticks. cleaned plunger and solenoid and sprayed with silicon, same problem. Replaced solenoid with a new one, same problem. I tap the solenoid and it shuts off.How can I fix the problem.