You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 2607 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Saturday, July 14th 2007, 10:43am

by SprinklerGuy

Do yourself a favor and call a technician...

Ken Wells bought my company and he is very honest, reliable and does good work.....

Email me your info...I will pass it onto him....I hesitate to post his number here....spam and all....but send me an email through this forum and I will forward to him....

The Imperials go bad after years of service...they can be repaired...but only a technician with experience will be able to differentiate between a timer problem and some valve problems...it sounds like you have a timer problem...but it could be the valves or wiring as well.....

Good luck...

Saturday, July 14th 2007, 9:10am

by Iphis

Imperial Valet Timer - Newbie

Hey there,

Totally new here, been doing a little research as we moved into this house last year and my Imperial Valet Timer just stopped working the other day. Sort of, I will try and explain.

Alright, first I'm not sure how to go about getting the model number, the sheet that explains how it works plastered in the housing did not say, I could only find the patent number 3736391. I doubt that will help, but yeah.

It seems to have 6 zones, it has a wheel with six stations on it. Each one has a dial that, I assume, sets the time the sprinkler will be on. It has a Manual, Off, Reset switch, a reset switch, a two-pin dial that will state what time the sprinklers will come on and the dial that shows what days of the week the shrubs and sprinklers will come on.

I live in Mesa Arizona (Near Phoenix).

Ok, basically I was noticing that only one set of my sprinklers were coming on, station 2. All the other grass locations were dying. I am only using station 1, 2, 3 and 6. I did not do any of the hook-ups, these were all done before we moved in.

When I went to go play with it, I could get station two to come on by moving the dial to the proper time, turning the manual on and turning the station wheel to 2. However none of the other stations will come on.

After this first time of getting it to work, it stopped after I turned it off and I could never get it to come on again.

Things I've noticed, when playing with it before, I could audibly hear when the water was going through the pipe to the sprinklers. My problem now is that none of the stations will come on, period. I cannot hear the pipes having water going through them anymore.

When I use manual and I turn the dial a little toward the number, it clicks away with one final louder click when it reaches it's station. Then after a three second pause, I hear a softer click from the reset switch.

I am not mechanically inclined in any sort, so if it is requiring manipulating wires that could zap the bejebus out of me, I would rather call someone. This is my first house, my first sprinkler system, so any advice, referals, or even telling me where, generally, I can call to have something like this looked at would be appreciated. I'm not sure if there are sprinkler technicians or if you have to call an electrician, or what. :)

Thanks again for helping me out!