You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 770 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Wednesday, June 13th 2012, 8:04am

by GatorGuy

Low pressure.
follow Boots suggestions.

Tuesday, June 12th 2012, 9:22pm

by mrfixit

Worn out seals in the sprinkler.

Break in the line somewhere.

Valve not coming on all the way. Open it with the bleeder screw and see if that helps.

Tuesday, June 12th 2012, 8:49pm

by ronzo1

Hunter PSP one zone won't pop up

out of three zones one won't pop up by itself, All 3 heads in that zone puddle water around top of head, if I manually force heads up then push them down all heads will come up slowly. once up they seem to work OK. filters in heads not clogged.



Appreciate your help



THX