You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 853 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 2 posts

Monday, April 30th 2012, 6:44pm

by mrfixit

Rick the problem isn't the sprinkler it's the valve. Water can't get to that sprinkler unless it gets past that valve.

Find the valve, take the bonnet off, inspect the diaphragm. There's a good chance there's debris stuck in the seat of the diaphragm. You may need to replace it.
Also look at the seat itself and see if it's pitted. Sometimes you can sand that out with some fine grit sand paper.

Monday, April 30th 2012, 5:23pm

by rickeyd

New sprinkler head leaking like old one.

I have put a new sprinkler head on. It leakes like the old one. When I unswrew the head off there is a costant drip.Looking for help. thanks Rick