You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1180 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 4 posts

Saturday, July 30th 2011, 5:59pm

by Wet_Boots

Good luck. If you knew how to upload photos to a site like imageshack, we could see what you're looking at. When you lack the experience to describe a problem, photos mean a great deal.

Saturday, July 30th 2011, 5:21pm

by aliceh@austin.rr.com (Guest)

It is broken..

I can't attach a photo, but since it's dry I can tell that it is broken. Now I am trying to figure out how to replace it?

Saturday, July 30th 2011, 4:57pm

by Wet_Boots

you need to provide a photo of the problem valve

Saturday, July 30th 2011, 3:30pm

by aliceh@austin.rr.com (Guest)

valve looks like it's broken...can't tell if it just needs to be screwed in

My valve looks like it just needs to be screwed in. I can't get it screwed back in. Water spews out. Is it broken or is it just tricky to screw it in?