You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 2951 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Saturday, August 19th 2006, 4:16am

by Wet_Boots

Try to find some 'King' drain fittings, they don't get clogged up.

Friday, August 18th 2006, 3:52pm

by xpedient

Put a plug in there...

Tuesday, July 25th 2006, 6:42am

by brotherbryce

valve not stopping water

I have to begin by saying I'm new to this sprinkler repair stuff. I just replaced my timer, then noticed some leaks in the system. I dug them up and they are some old orbit drain valves. They're draining water constantly. So I replace both drain valves and one still "leaks". So I replaced the control valve to the line, which had just started leaking also. That did not fix the problem. Any ideas?