You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1476 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 4 posts

Wednesday, October 6th 2010, 11:57am

by drsoma

Toro TR50 Hi-Pop Sever Leak

Thanks for both of your replies. I will check my units for the wiper issue, and will talk to my installer about pressure. I have a work-around in place now that satisfies my needs. Both units were to serve a vegetable garden, and I intend to replace the two with a drip system next spring. I do have a couple of other places where those hi-pop units would be useful, so solving the leakage problem would be most beneficial. I sure wish that I'd known of this forum a year ago. Again, many thanks.

Tuesday, October 5th 2010, 10:21am

by Wet_Boots

Water pressure may be the issue. Pressure sufficient to pop up a standard head may not be enough for a hi-pop head. The zone may need to be re-nozzled, to bring up the pressure.

Monday, October 4th 2010, 8:41pm

by Central Irrigation

The heads are either missing their wiper seals, or the cap that holds the head together is loose.

Sunday, October 3rd 2010, 9:25pm

by drsoma

Toro TR50 Hi-Pop Severe Leak

I installed two Toro TR50 Hi-Pop heads (same zone) to replace a standard TR50s so that I could spray over nearby plants. Both spouted water around the pop-up shaft, spraying very little. Nice fountains, but not exactly what I had in mind. I have had no response from either my installer from who I bought the heads (I did the replacement - a simple exchange of TR50 rotor heads), and nothing at all from Toro. Nice service.

Can you help me understand the problem? Or are these rotors perhaps defective? I had to pull them immediately and return to the standard rotors.