You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1523 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Friday, July 2nd 2010, 11:13pm

by mrfixit

I don't know what the hell a secondary is but just last week I blew two transformers on a water master controller which was fairly new. I wound up installing a new timer for him. It's only been a week or so but so far so good. I could smell something burning inside the controller. So to answer your question, I'd say yes the controller can burn out a transformer.

I suggested that maybe he'd had a power surge and he went on to tell me that a few neighbors lost an appliance or two in a recent blackout.

Friday, July 2nd 2010, 7:17pm

by Bentmynose

having same problem

I've just experienced the same issue .. two non-functioning transformers in one week. My initial thought was that the replacement transformer was just faulty.. but, when I read your question, it occurred to me that maybe it's something downstream that's causing these secondaries to fail.

Tuesday, June 29th 2010, 4:21pm

by jw452

Hunter Pro-C Controller

I replaced the transformer for my 2006 Pro-C, (from a Hunter Dealer) and it lasted for three days until it quit. There is no power on the secondary. Is there something in the controller that could fail, causing feedback to blow the secondary? How do I check the 9-station module for continuity? Could there be an issue with a solenoid which is causing this problem?

Thanks for any suggestions.