You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1468 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Saturday, April 17th 2010, 5:12pm

by jeffreyropp


mrfixit know his stuff!

For the benefit of others, I took a few pictures and video.
The washer (or more accurately, o-ring says my hardware store guy) was missing altogether.
$0.79 later, everything works!

http://www.youtube.com/watch?v=d676RSDblXE

Sunday, April 11th 2010, 9:52pm

by mrfixit

Excellent video. That valve sounds very labored. Looks like the flow control is turned way down. The valve is also very old. It might be on it's last legs. As far as the leak goes it's pretty simple. Take the cap off where it's leaking. There's a white float in there with a black rubber washer on it. Either that washer is broken, missing or loose. Or there's debris in there keeping the float from doing it's job. Could be as simple as replacing that washer. If you want a reliable sprinkler system I'd get rid of those two valves completly.
www.sprinklerwarehouse.com/Irritrol-2700-Series-Anti-Siphon-Valves-s/432.htm

Sunday, April 11th 2010, 8:21pm

by jeffreyropp

Sprinkler Valve Leaks When Open (video)

Hey everyone,
I recently took on the challenge of re-irrigating my backyard. Everything seems to be working as desired except this one valve. It only leaks when in the open position (see video below). Any hints on fixing the problem?

http://www.youtube.com/watch?v=ssmLjnEPuMI


Many thanks in advance,
Jeff