You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1968 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Saturday, August 1st 2009, 1:55pm

by hi.todd

Call a pro. :S



Pumps can be tricky.

Monday, July 27th 2009, 3:38pm

by Wet_Boots

There ARE times when it's okay to call in a professional. You could have something very, very simple to deal with. Or not. Some pump setups have the unfortunate ability to do themselves damage, if everything isn't just right.

Saturday, July 25th 2009, 7:31am

by lynn44

Only one zone will work

I recently purchased a house and I am unable get the sprinkler in working order. This unit has Richdel Controller and Amtek valves. It also has a well pump. I found the main breaker was defective as well as the relay calling for the pump to kick on. I bypassed the relay and changed out the breaker. Now the pump starts and one zone begins to spray. Unfortionately the zone is the only one that comes on regardless which zone in on in the control panel. It is the zone closet to the well pump. I have to shut down the well pump for value to stop.

Help..