You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1892 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The first post

Sunday, June 21st 2009, 12:40pm

by EtzGx

Irritrol KwikDial

Here is a link to what I have.

http://www.irritrol.com/controllers/controllers_kwikdial.html



When I tired to turn on my sprinklers the other day, it would not turn on. The numbers and letters on the display panel look sort of wiggly? they are not solid but wavy I guess is the best way to describe it. Also a battery sign comes up above for about 30 seconds. Not sure what to do about it, the system will not turn on at all. If anyone can help that would be so much appreciated. :?: ;(