You are not logged in.

Reply

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Attention: The last reply to this post was 1884 days ago. The thread may already be out of date. Please consider creating a new thread.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Tuesday, May 26th 2009, 10:55am

by Wet_Boots

22 gpm is rather below the operating range of any 2-inch valve, outside of those built for specifically drip.

It would be better to have some pressure on the supply side of the valve, before they open.

Tuesday, May 26th 2009, 8:53am

by worachj

That valve has an operational pressure range of 20-150 psi. It needs a minimum pressure of 20 psi to open/close. It could be a pressure/flow problem. I don’t know anything about pumps so I don’t have any suggestions on how to correct the problem other than switching to a valve with a lower operational pressure range. Sorry, maybe someone else can provide a helpful solution.

http://www.irritrol.com/pdf/sellsheet_200B.pdf

Tuesday, May 26th 2009, 2:09am

by Adryan (Guest)

Irritrol - Richdel 217B not fully opening

Hello all,



I have made a setup with 11 Irritrol / Richdel 217B - 2"valves. They are used to switch on / of the drip lines. I have a problem the valves are not opening fully every time..lets say they work o.k. for 50%. It are used valves. When I use the manual bleed screw the valve will fully open, and stay open untill the valve is switched of. I've cleaned everything out and can find any cracks/dirt in the valves. I'm using a low flow in the valves (22GPM, 45PSI). The controller works o.k., as are the sollenoids. The way the controller works is as follow: the valve is opened and a second later the pump is powered. The pressure is build up in the system in about 7 seconds to 45PSI, but the valves often don't fully open.

any input would be appriciated!

regards,

Adryan